2.0

2.1

Editing Programs

This chapter describes how to use the Editor to edit programs
offline. See chapter 5 for information about editing programs online.

Starting a Rung

The first step in entering ladder logic is inserting the first instruction
in the rung. Place the first instruction of a rung against the left power
rail.

All rungs are aligned against the left power rail.

To start a rung

Step 1. Click on the Ladder Language toolbar button that
accesses the group of instructions you need.

An instruction palette appears.

Step 2.  Point to the instruction you want to insert, and press and
hold the left mouse button.

Step 3.  While holding down the mouse button, drag the
instruction into the program area and next to the left
power rail. While you are dragging the instruction, the
cursor changes to indicate whether you can drop the
instruction and where it will be placed. Instructions

destined for the left power rail will look like |'| t or |'E'

Step 4.  When the instruction is where you want to place it,
release the left mouse button, dropping the instruction
into place.

IMPORTANT

You must place the first instruction of a rung so that it attaches to the
left power rail to start a rung. If you place it anywhere else in the
program window, you must then cut, paste, or drag to connect it to
the power rail. You cannot draw a wire to connect it to the left power
rail.

Tip
If you frequently use a particular instruction on a toolbar palette, you
may want to turn the toolbar palette on. Once a toolbar palette is on,

just point to the instruction you want to insert, and press and hold
the left mouse button to drag the instruction from the palette.
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Defining the Horizontal and Vertical Grid Limits Per
Rung
You can define limits for the size of the grid used by the Editor to lay

out each rung. This lets you make sure that your program printouts
fit on your preferred page size without the rungs being split up.

Relay instructions occupy a grid space of 1 x 1. More complex
instructions occupy at least 3 units horizontally by 2 to 8 units
vertically.

The default grid size per rung is 40 horizontal units by 24 vertical
units, which is also the maximum grid size per rung.

The Editor lets you place instructions outside the grid limits. Rungs
that exceed either limit cause a warning to be displayed during a
verify operation. The limits you set are checked only when you
perform a verify operation.

To define the horizontal and vertical grid limits per rung

Step 1.  From the Tools menu, choose Options. A tabbed dialog
box is displayed.

Step 2.  From the General tab, locate the Per Rung Instruction
Grid group box.

Step 3.  Enter the desired values for the Horizontal and Vertical
fields. The Editor uses these new values for all
subsequent programs you open.

Step 4.  Click OK to accept the new grid size.

Turning the Grid On and Off

Use the grid to help you see where instructions will be placed and
where you can draw wires. You can select whether to display the
grid used by the Editor to lay out rungs. The grid is displayed using
+ symbols.

To turn the grid on or off from the View menu
e From the View menu, choose Grid.

Selecting Rungs
Before you can copy, cut, or move a rung, you must first select it.
You can select a rung by doing any of the following:
e Click on or near the rung number.
or
e Click on the rung description text (when displayed).
or

® Draw a selection box around the entire rung. A selection box is a
dotted-line rectangle like this:

A selected rung looks like this: |—=-
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Tip

If rung numbers are not displayed, you can still select the rung by
clicking in the rung status area next to the rung.

To select a rung by drawing a selection box

Step 1.

Step 2.
Step 3.

Step 4.

Think of the rung you want as being enclosed in a box,
and position the pointer on the white space at either the
top or bottom “corners.”

Press the left mouse button. The cursor changes to +.

Draw a selection box around the rung by moving the
mouse diagonally across the rung. You cannot draw a
selection box to encompass more than one rung.

Tip
If the rung you are selecting extends beyond the screen
display, you can scroll the screen to display the

remaining rung logic by extending the selection box
against any side of the program window.

Once the rung is enclosed in the box, release the mouse
button. The rung is now selected.

To select multiple, contiguous rungs by dragging the mouse
Press and hold the mouse button in the rung status area, and drag

the mouse in either direction (up or down) to select additional rungs.

To select multiple, contiguous rungs by selecting the first and

last rung
Step 1.
Step 2.

Step 3.

Select a rung.

Scroll the screen as necessary to display the last rung
you want to select.

Hold down SHIFT and select the last rung by clicking in
the rung status area next to the rung.

To select all the rungs in a program

e From the Edit menu, choose Select All

or

® Press CTRL+A

or

e From the program window pop-up menu, choose Select All.

2-3



2-4

2.3

Entering Rung Descriptions

Rung descriptions help you document the program’s logic so that
others can understand the function of each rung and help make
troubleshooting easier. Rung descriptions can contain a maximum
of 16 lines, with each line containing a maximum of 80 characters of
text.

You must turn on rung descriptions to view them in the program.

To enter a rung description in the program window
Step 1.  Make sure Rung Descriptions are turned on.

Step 2.  Select the rung to which you want to add or edit a
description. The rung description field, which is a dotted
line box, is displayed above the rung. For more
information, see section 2.2.

Step 3.  Click in the rung description field and enter the
description.

Tips
e Start a new line by pressing CTRL+ENTER.

® Move around in the rung description field by using the mouse,
HOME, END and the arrow keys. Delete text by using
BACKSPACE or DELETE.

® You can also cut, copy, and paste text in rung descriptions. See
the AutoMax Ladder Editor and Enhanced Ladder Editor help file
for more information.

To enter a rung description in the Rung Properties dialog box

Step 1.  Select the rung to which you want to add or edit a rung
description. For more information, see section 2.2.

Step 2.  From the File menu, choose Properties.

Step 3.  In the Rung Description field, type in the description.
Step 4.  Click OK to add the description.

Tip

You can also access the Rung Properties dialog box from the

pop-up menu. Select the rung or point to it. Then, click the right
mouse button and choose Properties from the pop-up menu.
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Inserting Instructions into a Rung

Build a rung by using the mouse to drag and drop instructions from
an instruction palette and connect them together by drawing wires.
The program area is like a blank canvas—you drag instructions
from the instruction palettes and drop them in the program area. But
first, you must start a rung by dragging an instruction from an
instruction palette and dropping it very near the left power rail. To
help make inserting instructions easier, the insert cursor indicates
when and in which direction you can drop an instruction. See
section 2.1 for more information on starting a rung.

When dropped into the rung, the instructions indicate where you
can attach another instruction or wire. Contact instructions have
connections on either side, but coil instructions can only connect to
another instruction on the left side.

For instruction blocks like ADD, you can connect other instructions
to the longer lines. These longer lines attach to Boolean input and
output parameters.

An inserted instruction belongs to the rung above it if the newly
inserted instruction does not start a rung.

To insert instructions into a rung

Step 1. Click on the Ladder Language toolbar button that
accesses the instruction palette you want to use.

The instruction palette appears.
Step 2.  Point to the instruction you want to insert.

Step 3.  Press and hold the left mouse button while dragging the
instruction into the program area.

Step 4.  When the pointer is where you want the upper-left corner
of the instruction to be, release the left mouse button,
dropping the instruction into place.

If you drop an instruction very near another, the newly-placed
instruction automatically connects to the one adjacent to it. Similarly,
you can insert an instruction between two instructions by simply
dragging it between the existing two.

Tip
If you frequently use the instruction on a toolbar palette, you may

want to turn the toolbar palette on. See “Turning the Toolbars and
Palettes On and Off” in Appendix A.

Tip
If you delete or cut the first instruction of a rung, the left power rail

connection stays, indicating that you can insert a new instruction.
Insert the new instruction to the right of the left power rail connector.

Tip
You can move or copy one or more instructions from one rung and

insert them into another rung. See “Moving Instructions” and
“Copying Instructions” in the AutoMAx Ladder Editor online help.
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Connecting Instructions (Drawing Wires)

Connect instructions when you want to create branches (parallel
logic) or to connect two or more instructions together that were
placed too far apart for them to connect automatically. Connect
instructions by drawing wires.

You can use the grid markers to help you determine where
instructions will be placed and where you can draw wires.

To connect instructions

Step 1.  Place the cursor near a connection point for an
instruction. For relay logic, the connection point is either
the left side (for coils) or both sides (for contacts). For
block instructions, the connection points are the free
ends of the long lines.

When the cursor is near a connection point, it changes to

include a pencil: %‘?

Step 2.  Press and hold the left mouse button. The cursor
changes to a pencil.

Step 3.  Draw the wire by moving the mouse towards the
instruction to which you want to connect. You can draw a
continuous wire to connect instructions in a branch and
the coils at the end of the rung. A dotted line indicates
where the wire will be placed.

Step 4.  When you reach the destination connection point, release
the mouse button.

The wire is drawn to connect the instructions.

Connecting Multiple Instructions by Using
the ENO Output Bit

Quickly build a rung by connecting a relay instruction or a Boolean
input of an instruction to the ENO output parameter of an instruction
block. For example:

L EM

In

MOVE MOVE .
Out=In Out=In coil
END BN 277 A

BT1_DEST 0 BT1_UPDATE
Out In Out

The Boolean input parameter’s or relay instruction’s state is linked to
that of the ENO output parameter.

The ENO output parameter for an instruction follows the state of
that instruction’s EN input parameter unless an error occurs.
When an error occurs within an instruction, the ENO output
parameter is set according to the pre-defined variable
ERROR_ENO. Because the default value of ERROR_ENO is
false, instructions connected to the ENO output are disabled
when an error occurs in the instruction block containing the ENO
output. Should you want to continue evaluating and executing the
logic connected to an ENO output, set the variable ERROR_ENO
true.
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Selecting Instructions

Before you can copy, cut, clear, or move an instruction, you must
first select it.

To select an instruction

e Click on any part of the instruction such as the instruction itself, a
variable used in the instruction, or the description.

or

e Draw a selection box around the instruction. A selection box is a
dotted-line rectangle like this:

A selected instruction looks like this: |—=-=

To select an instruction by drawing a selection box

Step 1.  Think of the instruction you want to select as being
enclosed in a box and position the pointer on the white
space at either the top or bottom “corners.”

Step 2.  Press the left mouse button. The cursor changes to +.

Step 3.  Draw a selection box around the instruction by moving
the mouse diagonally across the instruction. Once the
instruction is enclosed in the box, release the mouse
button. The instruction is now selected.
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To select multiple, contiguous instructions by drawing a
selection box

® Draw a selection box to encompass the instructions you want to
select. You can only select instructions that belong to the same
rung.
or

Step 1. Select an instruction.

Step 2.  While pressing SHIFT, place the mouse pointer on the
selected instruction and press the left mouse button.

A selection box appears.

Step 3.  While holding down the mouse button, drag the selection
box to encompass the instructions that you want to
select.

Tip

If the instructions you are selecting extend beyond where they are

displayed on the screen, you can scroll the screen to display the

remaining instructions by extending the selection box against any
side of the program window.

About Instruction Properties

The Instruction Properties dialog box contains two tabs:

Use this tab: For:

Instruction ® changing the instruction’s type
Info

® viewing the variable names used in the
instruction’s input and output parameters

Variables ® viewing the variables used in the instruction
® entering a variable description

® changing variable’s data type, scope,
initialization, and display format

® specifying a maximum array index

To access Instruction Properties from the File menu
Step 1.  Select an instruction.

Step 2.  From the File menu, choose Properties. The Instruction
Properties dialog box is displayed.
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To access Instruction Properties from the pop-up menu

Step 1. Point to the instruction, and press the right mouse button.

Step 2.  From the pop-up menu, choose Properties. The
Instruction Properties dialog box is displayed.

To display the variable properties tab, choose Variables. To display
information about the instructions, choose Instruction Info. Quickly
toggle between the two tabs by using CTRL+TAB.

Changing an Instruction Type

You can change an instruction to another compatible instruction
without having to re-enter the variable names for the parameters.
This feature helps reduce the time required to make logic changes.

Compatible instructions are those with the same basic function
and/or the same number of inputs and outputs. For example, you
can change an NOI instruction to a NClI instruction because these
instructions are compatible relay input instructions. Conversely, you
cannot change an NOI instruction to a CO or an ADD instruction
because these instructions are not compatible.

To change an instruction type by using Find and Replace

Step 1.  Click on

The Find dialog box is displayed.
Step 2.  In the Objects group box, choose Instruction.

Step 3.  In the Find Instruction list box, choose the instruction for
which you want to search. This list only displays those
instructions that are compatible with the selected
instruction.

Step 4.  Choose Find.

The Editor searches the program for the instruction you
specified.

Step 5. Choose the Replace button.

Step 6.  In the Replace Instruction list box, choose the instruction
that you want to use in place of the instruction you are
searching for. This list only displays those instructions
that are compatible with the selected instruction.

Step 7.  Choose Replace to replace the current instruction with
the new one or Replace All to replace all occurrences of
an instruction with another.

To change an instruction type by using its Instruction Properties
Step 1. Select the instruction you want to change.

Step 2.  From the File menu, choose Properties.

Step 3.  Choose the Instruction Info tab.

Step 4.  From the Type list box, choose the instruction type that
you want to use in place of the selected instruction. This
list only displays those instructions that are compatible
with the selected instruction.

Step 5.  Click OK to accept the change.
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Tip
You can also access the Instruction Info tab from the pop-up menu.

Point to the instruction that you want to change, press the right
mouse button, and choose Properties from the pop-up menu.

Tip
You can also change the information about the variables used in the

instruction. Simply choose the Variables tab or press CTRL+TAB to
display the Variable Properties.

Tip
To select the instruction and access the pop-up menu, place the
mouse pointer over the instruction and click the right mouse button.

Assigning Variables and Constants to
Ladder Instruction Parameters

Each instruction includes at least one input or output parameter. The
more complex instructions contain parameters for multiple
non-Boolean inputs and outputs. Each parameter has a variable
name field in which you enter the variable name or constant that you
want to assign to the parameter.

To help make assigning variables to instruction parameters easier
and faster, variables are automatically assigned a default data type
and scope when they are first entered. The default type is that most
likely to be used by the instruction. For example, the default type for
a variable name entered for a relay instruction is Boolean. But for a
JMP, the default type is label. For most block instructions, the default
type for input and output parameters is integer.

When you enter an element-indexed variable, a default maximum
array index is automatically assigned, which you can later change in
the Variable Properties.

The scope of the variable is determined by the case of the first letter
of the variable name you type. If the letter is upper case, the variable
defaults to being a global variable. If the letter is lower case, the
variable defaults to being a local variable.

To assign variables or constants to ladder instruction
parameters

Step 1. Select the instruction for which you want to assign
variables. The variable name field appears as a
dotted-line box.

Step 2.  Click in this dotted-line box. The outline becomes solid
and a vertical text cursor appears.

Step 3.  Type in the variable name or a constant you want to use
following the naming conventions of the Editor. See the
reference information for the instruction you are
programming for more information about the allowable
variable types. The scope of a variable can be either
global or local. When you first enter a variable, its scope
is defined based on the case of the first letter you type.
An upper case letter defines the variable to be global. A
lower case letter defines it to be local. See section 2.15
for more information about a variable’s scope.
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Tip

If the variable has not been used before, a default data type and
scope is automatically assigned. If the variable is an array, the
maximum array index defaults to the value you entered as the
element of the variable. For example, if you entered part[5] the value
of 5 would be entered into the Maximum Array Index field of the
Variable Properties.

If the element-index of an array is a variable, the Maximum Array
Index field contains a value of 1.

Tip

If the variable has been used before, you can save typing by using
Variable Smart-Matching. See section 2.12 for more information
about Variable Smart-Matching.

Tip

To enter hexadecimal constants:

o End hexadecimal constants with an “h” or “H”.
For example: 607H

e [f the hexadecimal constant begins with a letter, enter a leading 0
before the value.
For example: 0A607H

e [f the most significant bit of the hexadecimal constant is set and
the constant is fewer than 8 digits, sign-extend it with “F’s” into
an 8-digit hexadecimal value.

For example: Enter 9C40H as OFFFF9C40H

The Editor converts a hexadecimal value to a decimal constant,
except for the logical and Masked Move instructions.

Entering Variable Descriptions

Variable descriptions help you document variables used in
instructions. Each variable can have its own description; however,
the description applies to simple or array variables and not to
indexed variable names. For example, the description displayed for
the variable TANK: fill would be for the variable TANK.

The descriptions can contain a maximum of 40 characters.
You must turn on variable descriptions to view them.

To enter a variable description by clicking into the variable
description field above a variable

Step 1.  Make sure that the variable descriptions are turned on.
Step 2.  Select the instruction.

Step 3. Click in the variable description field above the variable
for which you want to enter a description. When selected,
the variable description field is outlined by a solid border.

Step 4.  Enter a description containing a maximum of 40
characters.

Tip

A shortcut to entering a variable description is to click twice on the

variable name and press TAB to advance to the variable description
field. Enter a maximum of 40 characters of text.
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To enter a variable description by using the Variables tab in the
Instruction Properties dialog box

Step 1. Select the instruction that contains the variables you want
to document.

Step 2.  From the File menu, choose Properties. The Instruction
Property dialog box is displayed.

Step 3.  Choose the Variables tab. The Variables Properties box is
displayed.

Step 4.  In the Name list box, choose the variable you want to
document.

Step 5.  Click on the Description field, and type in the description.
Step 6.  Click OK to add the description.

Tip

You can also access the Variable Properties dialog box from the
pop-up menu. Point to the instruction containing the variables to

which you want to add or edit a description, press the right mouse
button, and choose Properties from the pop-up menu.

Tip
Move around in the name field by using the mouse, HOME, END,
and arrow keys. Delete text by using BACKSPACE or DELETE.

Tip
To select the instruction and access the pop-up menu, place the
mouse pointer over the instruction and click the right mouse button.

Using Variable Smart-Matching

Variable smart-matching is an option you can use to help you enter
variable names in less time. The Editor maintains an alphabetical
and case-sensitive list of variables you have used. When this option
is on and you begin entering letters in the variable name field, the
first variable name in the Editor’s list that matches the first letter or
letters you have typed appears in the variable name field. For
example, if you have previously used the variables “pump” and
“packet” and you type the letter “p” in a variable name, the word
“packet” is inserted into the variable name field. If “packet” is the
variable name you want, you can stop typing. If you had typed a “R”
global variables (which begin with an uppercase P) would have
been offered by the Variable Smart-Matching option.

If variable smart-matching displays a variable name that you only
want to use part of, you must delete the extra characters by pressing
BACKSPACE or DELETE.

To turn the Variable Smart-Matching option on and off

Step 1. From the Tools menu, choose Options. The Option dialog
box is displayed.

Step 2.  Choose the General tab and locate the Miscellaneous
group box.

Step 8.  Choose the Variable Smart-Matching option. This setting
applies to all subsequent editing sessions.

Step 4.  Click OK to accept the new setting.
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To scroll through the available variable names that match the
character(s) you have typed

e To advance, press CTRL and the down arrow.

® To move backward through the matching variable names, press
CTRL and the up arrow.

The Variable Smart-Matching option provides matches to each part
of an element-indexed and/or bit-indexed variable. Enter the
element-index or bit-index delimiter and the first letter or letters of
the element or bit name. Then, scroll through the variable name
choices offered. The choices offered by the variable smart-matching
option are determined by how many letters you type in.

Tip
e To append onto a variable name picked from the variable

smart-match choices, make sure the variable name is not
selected before continuing to type.

e To re-initialize smart-matching, delete characters (by using
BACKSPACE), and re-type one or more.

Tip
If you type a question mark (?) as the first letter of a variable name,

the Editor automatically smart-matches on the first variable in your
variable list.

Selecting Variable Names

Before you can copy, cut, or clear a variable name you must first
select it.

To select a variable

Step 1. Select the instruction that contains the variable you want
to edit. The variable name fields appear as dotted-line
boxes.

Step 2.  Click the dotted-line box. The outline becomes a solid
box and the text is selected.

Changing a Variable’s Data Type

When you enter a variable name in an instruction’s input or output
parameter, a default data type is assigned based on the instruction
type. If you want to change a variable’s data type to something other
than the default, you can change it by using the Variable Properties
tab.

IMPORTANT

Changing the properties of a variable affects the variable, not just a
particular instance in which it is used. For example, if you change
the data type of a variable from timer to integer and that variable
happens to be used in a TON instruction, this integer variable will no
longer be allowed within the instruction.
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To change the data type for a variable

Step 1. Select the instruction containing the variable whose data
type you want to change.

Step 2.  From the File menu or the pop-up menu, choose
Properties. The Instruction Properties dialog box is
displayed.

Step 3.  Choose the Variables tab. The Variable Properties tab is
displayed.

Step 4.  If the name of the variable you want is not displayed in
the Name field, use the list box to scroll through a list and
choose it. The Variable Properties dialog box for that
variable is displayed.

Step 5.  Using the Type list box, choose the data type for the
variable.

Step 6.  Click OK to accept the change.
Tip
Integer variables default to a 16-bit integer. If you want the variable

to be a double integer (32-bits), you must change its type to double
integer.

Tip
Quickly toggle between the Instruction Info and Variables tabs by
using CTRL+TAB.

Tip
To select the instruction and access the pop-up menu, place the
mouse pointer over the instruction and click the right mouse button.

Changing a Variable’s Scope

The scope of a variable can be either global or local. When you first
enter a variable, its scope is defined based on the case of the first
letter you type. An upper case letter defines the variable to be
global. A lower case letter defines it to be local. You can change a
variable’s scope by using the Variable Properties tab.

Compound variables (element-indexed or bit-indexed variable
names) are treated as separate variables with their own properties,
including scope. For example: TANK fill is a compound variable.
TANK is a global variable and fill is a local variable. For
element-indexed and bit-indexed variables using a number as the
index, the scope of the variable is determined by the named
variable. For example, the scope of the variable TANK.31 would
would be determined by TANK, which would appear in the variable
list. If the variable were TANK.31, only TANK would appear in the
variable list and have a scope.

IMPORTANT

Changing the properties of a variable affects the variable and not
just a particular instance in which it is used. If you change a
variable’s scope, the change applies to every instance where that
variable is used.



To change a variable’s scope

Step 1.

Step 2.

Step 3.

Step 4.

Step 5.

Step 6.
Tip

Select the instruction containing the variable whose
scope you want to change.

Access its Instruction Properties by choosing Properties
from either the File menu or the pop-up menu. The
Instruction Properties dialog box is displayed.

Choose the Variables tab. The Variable Properties tab is
displayed.

If the name of the variable you want is not displayed in
the Name field, use the list box to scroll through and
choose it. The Variable Properties tab for that variable is
displayed.

Click on either the Global or the Local option. The
variable name changes to be either all upper case or
lower case, depending on which option you chose.

Click OK to accept the change.

Quickly toggle between the Instruction Info and Variables tabs by
using CTRL+TAB.

Tip

To select the instruction and access the pop-up menu, place the
mouse pointer over the instruction and click the right mouse button.
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