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Getting Familiar with
the Editor

This section describes some basic information to help you become
familiar with the Editor.

Overview of the AutoMax Ladder
Editor Window

Instruction Palette
Standard Toolbar Menu Bar Program Windows

Editor Window
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imized Program Status Bar

Ladder Language Toolbar: Provides access to the individual
ladder instruction palette

Standard Toolbar: Provides shortcuts to common commands by
clicking on a button

Editor Window: Identifies the name of the currently active
program and provides access to the application window controls
Instruction Palette: Lets you drag and drop instructions into
your program

Menu Bar: Provides access to the available Editor commands,
many of which can be accessed via a standard toolbar button or
keyboard characters
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e Program Windows: Presents the open program(s). The name of
the program is listed in each window

e Rung Status Area: Displays rung numbers, revision marks, set
triggers, and indicates active versus non-active powerflow

e Minimized Program: Can help organize many open programs

e Status Bar: Displays information about the program objects you
have selected, the state of the program in the active window, and
helpful messages

Refer to Appendix A for more information about the toolbars,
instruction palettes, and the status bar.

Opening Programs

Opening a program is the first step in editing it. Before you can open
a program, you must have added it to the rack using the Task
Manager application.

You can open a program from the Task Manager application or from
the AutoMax Ladder Editor.

To open a program from within the Task Manager application

® From the Task Manager application, select a task and choose
Edit from the Task menu.

To open a program from within the Editor

Step 1.

Step 2.

Step 3.

Step 4.

Do one of the following:

e Click on

or

® From the Ladder Editor’s File menu, choose Open

The Open dialog box is displayed.

Choose the location of the file that you want to open. The
default drive and directory is the drive and directory from
which a program was last opened.

To change this:

Do this:

The drive and
directory in which to
search

Click in the Look in list box. From
here choose the drive and directory
that contains the program you want to
open.

The directory in which
to search

Click on a folder or on a file in the list
of files and folders contained within a
directory.

From the list of file names, select the program you want
to open. The default file type is ladder programs (*.pc).
You can open only .pc programs using the Ladder Editor.

Open the file by clicking OK.

If the ladder program was created using an older version
ladder editor, the Editor first prompts you to convert the
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program. To convert the program, choose Yes. For more
information, see Appendix F.
You can have at most 15 unique offline programs opened at one
time.

Closing Programs

Close the active program with the Close command. The Editor stays
active and any other open programs stay open.

The Editor prompts you to save any changes to open programs
before closing.

To close a ladder program

Step 1.  From the File menu or Program Control Menu, choose
Close.

Step 2.  If you have made changes to the program since you last
saved it, choose one of the following buttons in the
message box that asks if you want to save the changes:

To: Click:
keep the changes Yes
not save the changes No

keep the program open Cancel
and cancel the changes

Saving Programs

Save changes to the active, offline program by using the Save
command. The Editor stays active with the same program open after
saving the changes.

To save a ladder program

e (Click on

or

e From the File menu, choose Save

The Editor saves global and local variables and their descriptions to
the program symbol table.

Tip

Any offline revision marks present in the program disappear once
you save a program.

Tip

To save changes made to an online program, use the Accept or

Commit Test Mode Changes commands. For more information, see
Chapter 5.0.
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Saving Programs Automatically As
You Work

To make sure that you do not lose work, you can use the Automatic
Save Every feature to save your offline ladder programs at a
specified interval —for example, every ten minutes. Specify whether
you want your programs to be saved automatically and the time
interval to use within the General Options tab.

Files that are saved automatically are stored in the same directory
as the original ladder program and under the same name. However,
the file extension for an automatically saved file is .ASV.

To automatically save programs as you work
Step 1. From the Tools menu, choose Options.
Step 2.  On the General tab, choose Automatic Save Every.

Step 3.  Using the Minutes spinner box, choose or type the time
interval (in minutes) that you want the Editor to wait
before it automatically saves the ladder program. Choose
an interval from 1 to 120 minutes. The default setting is 10
minutes.

The program is saved at your specified time interval whenever a
change to the program has been made since the last automatic
save.

If a program you are trying to open has a more current autosaved
copy, the Editor prompts you to choose either the autosaved file or
the program file you last saved.

The auto-saved copy of a ladder program is deleted whenever you
save the program by using the Save command or close the
program.

Displaying a Program in Multiple Windows

To help you simultaneously view different parts of a program, you
can choose to display it in more than one window. Any changes you
make to the program are reflected in the other window(s) in which
the program is displayed. When you open a new window, it
becomes the active window and is displayed on top of all other
open windows.

To display a program in multiple windows

Step 1.  Make sure that the program you want to display in a new
window is the active program.

Step 2. Do one of the following:

® From the Window menu, choose New Window.
or

e With no program items selected and the mouse
pointer positioned in the grid area, click the right
mouse button, and choose New Window from the
pop-up menu.

The program window name is appended by a “:#”. For example, if
you chose to display the program LINE_1.pc in a new window, the
new program window would be LINE_1.pc:2.
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Editing Different Parts of the Same
Program Using Split Windows

A program window may be split into two horizontal panes. Any
editing done in one pane is reflected in the other.

Each pane can be scrolled independently using its own vertical
scroll bar.

To view different parts of the same program using the Split
command

Step 1.  From the Window menu, choose Split. The cursor turns
into a split pointer, a combination up arrow and down
arrow.

Step 2.  Using the mouse or the up and down arrow keys,
position the cursor at the point in the program where you
would like to split the screen.

Step 3.  Press ENTER or click the mouse button once to position
the split between the panes.

To view different parts of the same program by clicking on the
splitter bar

e While pointing to the splitter bar, press the left mouse button,
drag the splitter bar to the desired location, and release the
button.

To remove the splitter bar

e Click on the splitter bar and drag it to the top or bottom of the
window.

or

® Double-click anywhere on the splitter bar.

Editing Multiple Programs

You can edit multiple programs (up to 15) within the Editor at the
same time. Each program has its own window. Only one window at
a time can be the active window, which you can identify by the
highlighted title bar and rung status area.

To edit multiple ladder programs from the Task Manager

Step 1.  From the Task Manager, select each ladder program that
you want to edit.

Step 2.  From the Task Menu, choose Edit. The files you selected
are opened along with the Editor.

Step 3. From the Editor’'s Window menu, select Tile or Cascade.
All non-minimized programs are arranged within the
Ladder Editor window. Or, use the mouse to arrange the
windows on the desktop.

Step 4.  Click on the program window to make it active before
editing the program.
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To edit multiple ladder programs from the Editor

Step 1. From the File menu, open all the programs you want to
edit.

Step 2.  From the Window menu, select Tile or Cascade. All
non-minimized programs are arranged within the Ladder
Editor window. Or, use the mouse to arrange the windows
on the desktop.

Step 3.  Click on the program window to make it active before
editing the program.

Tip
To switch among the programs you are editing, press CTRL+F6.

Displaying/Hiding Revision Marks While
Editing Programs Offline
Revisions are always displayed while you are editing a program

online. But you can choose to display offline editing revision marks.

Revisions are marked by a letter in the rung status area and by the
modified rung color.

Letter | Meaning

M Logic was modified, or wires have been added
or deleted.

| The rung has been inserted.
D The rung has been deleted.

Tip
If you delete a newly inserted rung before committing or saving the

change, the rung is deleted. However, it is not marked with a “D”
revision mark.

To display/hide revision marks while editing programs offline

Step 1. From the Tools menu, choose Options. A tabbed dialog
box is displayed.

Step 2.  From the General tab, locate the Miscellaneous group
box.

Step 3.  Choose the Show Revisions While Offline Editing option.
This setting applies to the current and subsequent Editor
sessions until you change the setting again.

Step 4.  Click OK to accept the new setting.
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About Program Properties

The Program Properties dialog box contains three tabs:

Use this tab: | For:
Program Info | viewing information about the program

Scan Info defining how the program should be
scanned and the program’s scan time.

Error Log viewing the online error log

To access Program Properties from the File menu
Step 1.  Make sure no rung or instruction is selected.

Step 2.  From the File menu, choose Properties. The Program
Properties dialog box is displayed.

To access Program Properties from the pop-up menu

Step 1. Make sure no rung or instruction is selected, and position
the mouse in the program’s grid area away from any
instruction or wire.

Step 2.  Press the right mouse button. A pop-up menu is
displayed.

Step 3.  From the pop-up menu, choose Properties. The Program
Properties dialog box is displayed.

See the AutoMax Enhanced Ladder Language Reference manual,
J2-3094, for how to interpret the entries in the error log. See section
1.11 below for defining program scan time.

About Program Execution

Programs can execute by being scanned or event-driven. An event
is a flag or indicator that one program can set or raise and another
program can wait for.

Scanned programs execute based on the scan time in ticks you
define. For a ladder program, you can define how often you want
the program to execute by defining scan time in ticks. The actual
scan time of a program is determined by this formula:

scan time (ms) = tick rate of the Processor module * number of
ticks.

You define the tick rate for the Processor module when you add it to
your rack configuration. By changing the tick rate, you can change
the time base for program execution. This allows you to run a
program based on a unit of your choice. You can set the tick rate in
increments of 0.5 ms between 0.5 ms and 10.0 ms. The default
value is 5.5 ms. The tick rate is defined separately for each
Processor in a rack. For more information, see section 1.11.1.

Event-driven programs can be controlled by either hardware events
or software events. When an event-driven is first started (run), the
program executes once to completion. After this initial execution, the
program then waits for the designated event to occur. If you have
program logic that you do not want to run during the initial execution
of the program, use the pre-defined first_scan variable. An example
is shown here:
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Hardware events are generated by an external condition. These
AutoMax modules can set a hardware event:

e UDC module (57652)

® Pulse Tach Input module (57C421)

® Resolver Input module (57C411)

e 2-Channel Analog Input module (57C409)

e 32-Bit Digital Input module (57C419)

However, hardware events cannot be used on the AutoMax PC3000.
See a module’s instruction manual for information about interrupts.
For more information, see section 1.11.2.

Software events are flags generated by other programs. Software
events can be set by BASIC, control block, or ladder programs. For
information about programming software events, see your
programming language’s instruction manual and section 1.11.3.

Specifying a Scan Time To Control Program
Execution
For a ladder program, you can define how often you want the

program to execute by defining scan time in ticks. The actual scan
time of a program is determined by this formula:

scan time (ms) = tick rate of the Processor module * number of ticks

Define the scan time by using the Scan Info tab under Program
Properties.

To define how often you want your program to execute

Step 1. Access Program Properties. Make sure no rung or
instruction is selected, and choose Properties from the
File menu.

Step 2.  Choose the Scan Info tab.
Step 3.  Select Scanned for the Scan Mode.

Step 4.  Inthe Scan Time (ticks) field, enter the number of ticks
you want to use. Enter a value from 1 to 32767. The
default value is 20.

For example, if you want a program to execute every 30
ms, and the Processor has a tick rate of 3 ms, enter 10 in
the Scan Time field.

Step 5.  Click OK to accept the changes.

Specifying a Hardware Event To Control Program
Execution

Hardware events are generated by an external condition, such as a
digital input or a programmed hardware event from a Resolver
module. Specify the hardware event that triggers a program’s
execution by using the Scan Info tab under Program Properties.
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You can specify a timeout for the hardware event. This lets you
specify the maximum amount of time in ticks that can pass before
the hardware event occurs. You can use a timeout as a safeguard in
case something happens to the module you are using to generate
the hardware event. If the event does not occur before the timeout
time, a rack STOP ALL error occurs.

To specify a hardware event

Step 1.  Access Program Properties. Make sure no rung or
instruction is selected, and choose Properties from the
File menu.

Step 2.  Choose the Scan Info tab.
Step 3.  Select Event Driven for the Scan Mode.
Step 4.  Select Hardware as the Event Type.

Step 5.  In the Name field, type the name of the hardware event
that will trigger the program’s execution.

Step 6.  Inthe ISCR Variable Name field, type the name of the
variable associated with the ISCR (Interrupt status and
control) register on the hardware module being used to
generate the interrupt.

Step 7. Do one of the following:

To: Do this:
specify a timeout for the a. Select the Timeout
hardware event Enabled

b. Enter an integer value
between 1 and 32767

You should set the timeout to
a time longer than what you
expect the actual time will be.
A good general rule is 1.5
times longer than the
expected time between
events.

not use a timeout Make sure the Timeout
Enabled checkbox is not
selected.

8. Click OK to accept the changes.

Specifying a Software Event To Control Program
Execution
A software event is a flag set by another program. Specify the

software event that triggers a program’s execution by using the
Scan Info tab under Program Properties.

To specify a software event

Step 1. Access Program Properties. Make sure no rung or
instruction is selected, and choose Properties from the
File menu.

Step 2.  Choose the Scan Info tab.
Step 3.  Select Event Driven for the Scan Mode.
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Step 4.  Select Software as the Event Type.

Step 5.  In the Name field, type the name of the software event
that will trigger the program’s execution.

Step 6.  Click OK to accept the changes.

Running and Stopping Ladder Programs

Use the Online Task Manager to place a program into run or to stop
a program. If you are editing online, you must pause the Editor
before you can access the Online Task Manager, since they both
share the same communication channel. See “Pausing the Editor,”
section 5.3, for more information.

Exiting the Ladder Editor

Exit the Editor with the Exit command. The Exit command closes all
program windows and closes the Editor.

The Editor prompts you to save any changes to open programs
before exiting. If you choose to close an online program that has
changes that have not been accepted, the Editor prompts you to
return to the editing session or close. Selecting close discards all
the changes.

To exit the Editor
Step 1. From the File menu, choose Exit.

Step 2.  If you have made changes to any open ladder program
since you last saved it, choose one of the following
buttons in the message box that asks if you want to save
the changes:

To: Click:
keep the changes Yes

not save the changes | No

not close the program | Cancel

Tip
You can also exit the Editor by choosing Close from the Editor
Control menu.



